Xperia S(LT26i)にandroid4.1.1(Jelly Bean)をインストール。

ちょっと覚書程度に。

メインで話し合われているのはFreeXperiaProjectの皆様が開発中のCM10ベースのカスタムロム。

正直言って、メインで使うにはまだまだキツイですね。
ROM焼きが趣味の方向け用。

前提条件として、もちろんですが

  • bootloaderはunlockされている
  • fastbootモードでのコマンドが使える状態になっている
  • CWMでバックアップをとっておく。

ということが必要です。

また私の環境は

  • Ubuntu12.04

で作業しています。コマンドはUbuntuの端末ですがWindowsでも同じようにできると思います。

 

CM10のROMをダウンロード

XDAのポスト2番目

こちらからダウンロードができます。
署名にリンクがしてあるので、分かりづらいですよね。
今回は「cm-10-20120720-UNOFFICIAL-nozomi.zip」を小一時間かけダウンロードしました。

続いてGAPPSのダウンロード

ポスト1番目の投稿者の署名のところに

CM10 GAPPS ADDON
http://goo.im/gapps/gapps-jb-20120726-signed.zip

とあるのでそこからJelly Bean用のGappsをダウンロードしておきます。

インストール方法

一応、

  1. Install a Recovery (there are some around this forum)
  2. ?Flash Rom
  3. Flash gapps
  4. Wipe (only required 1st time)
  5. Flash kernel (fastboot flash boot boot.img)

と書いてあるのですが、このとおりだとインストールできませんでした。

ポスト120番目のやり方で無事にインストールできました。

(1)先ほどダウンロードしたCM10のZIPファイル内にあるboot.imgを取り出す。
fastbootコマンドでflash

$fastboot flash boot boot.img

 

(2)再起動してリカバリモードに入る。
→電源ONからボリュームアップを連打しておけば、入れます。

(3)リカバリに入ったら、「mount & storage」へ行って、mount/system > format systemを実行。

(4)その後、すべてunmountする。
画面上の表示が「mount/system」となっていればunmountされている。

(5)「install zip for sd card」から先程のCM10のzipファイルをインストール。

(6)続いて、GAPPSをインストール。

(7)「wipe data/factory reset」「wipe cache partition」を実行。さらに 「advance」から「wipe dalvik cache」と「wipe battery」

(8)再起動

使ってみた感想

これで起動するにはしました。
データ通信も大丈夫です。

カメラが起動してもノイズが入って使い物にならなかったです。

LEDが点灯しっぱなし。困る。

あと、お約束事ですがXperia Sがうんともすんとも言わなくなったら「ボリュームアップ+電源ボタンを長押し」で強制的に再起動できます。
一度、バイブが唸って、そのあと連続3回のバイブが動けばオッケーです。

使い物にならないので、ICSに戻します・・・。

コメントを残す

メールアドレスが公開されることはありません。

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください